Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 04, 2026 - 23:00 MDT
Scheduled
Please see the below maintenance advisory regarding GPAPI PROD 2.3 Release scheduled for 5th May 2026.
Scheduled Maintenance: GPAPI PROD 2.3 Release Effective: May 5, 2026
Please be advised Global Payments will be performing GPAPI PROD 2.3 Release to the production environment on Tuesday, May 5th, 2026. This maintenance is scheduled to begin at 01:00 A.M. ET and end at 08:00 a.m. ET same day.
During the maintenance window we do not expect any impact. If you experience any issues, please follow the established escalation procedures.
As always, please do not hesitate to contact your Global Payments Relationship Manager with any questions regarding this announcement.
Posted Apr 30, 2026 - 12:43 MDT
This scheduled maintenance affected: Global Payments - Canada (GPAPI Canada).