Global Payments System Incident - Some NWS Debit Merchants Experiencing Issues

Incident Report for Global Payments

Resolved

This issue was resolved when an issue with NWS Debit Card transactions was resolved and merchants were able to process NWS Debit Card transactions successfully once again.

Our teams worked with our Debit vendor to resolve the issue and get NWS Debit Card transactions processing again. This issue is now resolved.
Posted Aug 05, 2025 - 15:39 MDT

Investigating

We are aware of an issue for some merchants with NWS Debit Card transactions and we are investigating this matter further with our vendor.

Our teams are working with our Debit vendor to resolve the issue as quickly as possible.
We will provide regular updates until the situation is corrected.
Posted Aug 05, 2025 - 14:44 MDT
This incident affected: Heartland (NWS / PetroPay).