GPC Courtesy Advisory - August 6th, 2026 - Interac Mobile TSP - Google Pay Maintenance

Scheduled for Aug 5, 22:00 MDT  -  Aug 6, 01:00 MDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 22, 2026 - 14:07 MDT

Scheduled

GPC has been informed by Interac of an upcoming scheduled Maintenance event.
Planned Start Date/Time: August 6th, 2026 - 00:01 EDT

Planned End Date/Time: August 6th, 2026 - 03:00 EDT
Provider Performing Maintenance: Interac

Description: Interac is performing an application maintenance for Google Pay services

Service Affected: TSP - Google Pay
Issuer: All

Impact: During this maintenance window, Google Pay services, including transaction processing, card provisioning might be impacted, for all issuers. There is no impact to Samsung Pay and Apple Pay.

Interac Change #: 93618

Please note that Interac performs this maintenance and is external to Global Payments.

For any questions or inquiries about this notification please contact the relationship Manager or GNAP Support Team: GNAP_Prod_Support@globalpayments.com
Posted Jul 22, 2026 - 13:26 MDT
This scheduled maintenance affects: Global Payments - Canada (GSAP Canada, GNAP Canada, Portico Canada ATL/RIC, Portico Canada GCP, GPAPI Canada).