EVO System Incident - Network Issue

Incident Report for Global Payments

Resolved

This incident has been resolved and all systems are fully operational. Teams will work on steps for remediation and prevention of future occurrences.
Posted Sep 26, 2023 - 20:07 MDT

Update

Transaction processing has returned to normal. We have received reports of intermittent issues with inbound calls to our call centers, and our teams are working to resolve them.
Posted Sep 26, 2023 - 18:27 MDT

Update

At this time all systems are operational. We are continuing to monitor and to take steps to prevent further issues.
Posted Sep 26, 2023 - 15:17 MDT

Update

We are continuing to monitor. Most platforms are functioning as expected and we will continue to work on this issue until all systems are fully operational.
Posted Sep 26, 2023 - 13:20 MDT

Monitoring

Our technical teams have taken steps to resolve the issue and are seeing improvement. They are continuing to monitor the results.
Posted Sep 26, 2023 - 12:00 MDT

Investigating

We are aware of an issue impacting authorizations and are investigating this matter further.

Our teams are working to resolve the issue as quickly as possible.
We will provide regular updates until the situation is corrected.
Posted Sep 26, 2023 - 11:01 MDT
This incident affected: EVO.