Global Payments Incident Notification - Google Issue Impacting Some Global Payments Merchants

Incident Report for Global Payments

Resolved

Google applications have recovered and we have seen that Google application failures have ceased within the last few minutes. Teams will continue to monitor applications to ensure that all service issues have been resolved.
Posted Jun 12, 2025 - 14:36 MDT

Monitoring

We are aware of an issue with some Google applications or applications utilizing Google and we are investigating this matter further. This issue is external to Global Payments.

Our teams are working with Google for updates as they work on this issue to resolve it as quickly as possible.
We will provide regular updates as information becomes available from Google.
Posted Jun 12, 2025 - 13:52 MDT
This incident affected: Global Payments - Canada (GPAPI Canada).