Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 02, 2025 - 22:00 MDT
Scheduled
Global Payments will be performing unscheduled network maintenance on the Tempe Data Center starting Tuesday, September 2, 2025, at 10:00 PM MT until Wednesday, September 3, 2025, at 6:00 AM MT.
Maintenance will again take place on the Suwanee Data Center starting Thursday, September 4, 2025, at 10:00 PM MT until Friday, September 5, 2025, at 6:00 AM MT.
During this time, there should be minimal transactional service interruptions for Sierra, Saratoga, Summit, and Transit. Users may see brief disconnects during this maintenance window.
Posted Sep 02, 2025 - 16:50 MDT
This scheduled maintenance affected: TransIT (Merchant Center, Hosted, WebPASS / Virtual Terminal, CounterPASS/POS, MultiPASS / API Integration, Mobile Payment Acceptance, Settlement / Funding, Auto-Boarding) and TSYS Merchant Authorization Platform/Core (Saratoga, Sierra, Summit).