Global Payments System Incident - Sporadic Time Outs and Declines on Exchange

Incident Report for Global Payments

Resolved

Monitoring has been successful and no additional time outs or declines have been seen. Exchange processing has returned to normal and this issue is now resolved.
Posted Mar 20, 2026 - 19:02 MDT

Monitoring

Technical teams have implemented a fix for this issue and we are monitoring the system to confirm that the issue is fully resolved. As a result of the fix, transaction processing appears to have returned to normal. Teams will continue to monitor for a time to ensure that the issue is fully resolved.
Posted Mar 20, 2026 - 18:44 MDT

Investigating

We are aware of an issue with the Exchange platform and teams are investigating this matter further.

Our teams are working to resolve the issue as quickly as possible.
We will provide regular updates until the situation is corrected.
Posted Mar 20, 2026 - 18:34 MDT
This incident affected: Heartland (Exchange).