Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 25, 2025 - 22:01 MDT
Scheduled
Global Payments will be conducting routine scheduled maintenance on Monday, August 25th, beginning at 10:00 PM MT. This maintenance will conclude by 6:00 AM MT, on Tuesday, August 26th. As a reminder, during this window VARs, Point of Sale, and gateway providers will want to make sure they are properly balanced between the east and west coast data centers.
If they are load balanced between the east and west, they should experience minimal interruptions during this time.
VARs, Point of Sale, and gateway providers pointing to the east coast only will want to repoint all activity to the west coast (Tempe - 64.66.52.x) by 7:00 PM MT to minimize service disruption in advance of the change window.
Posted Aug 25, 2025 - 14:41 MDT
This scheduled maintenance affected: TransIT (Merchant Center, Hosted, WebPASS / Virtual Terminal, CounterPASS/POS, MultiPASS / API Integration, Mobile Payment Acceptance, Settlement / Funding, Auto-Boarding).