This issue has been resolved. Global Payments technical teams have confirmed that they are no longer seeing impact, and Mastercard has confirmed the issue is resolved.
This issue was external to Global Payments.
Posted Aug 15, 2026 - 00:26 MDT
Identified
We are aware of an issue with Mastercard transactions and are working with Mastercard. This issue is external to Global Payments.
Our teams are working with Mastercard to understand and mitigate the issue as quickly as possible. We will provide regular updates until the situation is corrected.
Posted Aug 14, 2026 - 23:58 MDT
This incident affected: Heartland (NWS / PetroPay, VAPS, Exchange, Portico, GSAP-NA) and Merchant Authorization Platform/Core (Sierra).