Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 14, 2024 - 02:00 MST
Scheduled
Global Payments will be performing unscheduled maintenance on the Ovation Point of Sale application starting on Thursday, November 14, 2024.
Devices will need to have at least 50% battery power whether it is plugged in or not and will need to be connected to a strong Wi-Fi connection during this time. This large file download will take approximately 15 minutes to complete.
After the download is completed, merchants will be prompted to install the application. If no action is taken within 60 seconds, the application will start to auto-install.
For merchants that turn off their terminals, devices will be prompted to initiate this process once turned back on. The entire process will take approximately 25-30 minutes to complete.
During this time, users will not be able to use the point-of-sale devices.
Posted Nov 13, 2024 - 13:43 MST
This scheduled maintenance affected: Ovation POS (Platform Overall, Server & Platform Connectivity (API), Back Office (Portal)).