Global Payments System Incident - Interac Debit Cards Processing Issue - Canada

Incident Report for Global Payments

Resolved

Service: Interac Debit Card
Impacted Segment: Canada

Impact Start time: 06/05/2025 - 11:08 ET
Impact End time: 06/05/2025 - 11:25 ET

Restored: This issue has been resolved as of 11:25 AM ET. GP has conducted a thorough investigation, which indicated that the issue appears to be external to GP. GP is still investigating with Interac to determine the root cause.

Summary: Global Payments' merchants may have experienced intermittent timeouts when processing Interac Debit Cards. No further timeouts have been observed as of 11:25 ET. Support Teams are still monitoring.

Actions Taken: Global Payments is currently investigating the issue with Interac.




Service: Cartes de débit Interac
Segment impacté: Canada

Début de l’impact: 06/05/2025 - 11:08 HE
Fin de l’impact: 06/05/2025- 11:25 HE

Rétabli: Ce problème a été résolu à 11 h 25 HE. GP a mené une enquête approfondie, qui indique que le problème semble externe à GP. GP enquête toujours avec Interac pour en déterminer la cause principale.

Résumé: Les marchands de Global Payments peuvent rencontrer des délais d'attente intermittents lors du traitement des cartes de débit Interac. Aucun autre délai d'attente n'a été constaté à partir de 11 h 25 HE. Nos équipes de support continuent à surveiller la situation.

Action prise: Global Payments enquête actuellement sur le problème avec Interac.
Posted Jun 05, 2025 - 10:47 MDT

Investigating

Service: Interac Debit Card
Impacted Segment: Canada

Impact Start time: 06/05/2025 - 11:08 ET
Impact End time: 06/05/2025 - 11:25 ET

Summary: Global Payments' merchants may have experienced intermittent timeouts when processing Interac Debit Cards. No further timeouts have been observed as of 11:25 ET. Support Teams are still monitoring.

Actions Taken: Global Payments is currently investigating the issue with Interac.




Service: Cartes de débit Interac
Segment impacté: Canada

Début de l’impact: 06/05/2025 - 11:08 HE
Fin de l’impact: 06/05/2025- 11:25 HE

Résumé: Les marchands de Global Payments peuvent rencontrer des délais d'attente intermittents lors du traitement des cartes de débit Interac. Aucun autre délai d'attente n'a été constaté à partir de 11 h 25 HE. Nos équipes de support continuent à surveiller la situation.

Action prise: Global Payments enquête actuellement sur le problème avec Interac.
Posted Jun 05, 2025 - 10:06 MDT
This incident affected: Global Payments - Canada (GNAP Canada).