We are no longer seeing transaction issues. This issue is resolved.
Posted Nov 17, 2025 - 12:06 MST
Monitoring
Technical teams have taken steps to restore services and most transactions are processing successfully. The debit/EBT vendor has stated their services are restored. Teams are performing additional restoration steps and we are continuing to monitor the situation.
We will provide regular updates until the situation is resolved.
Posted Nov 17, 2025 - 11:54 MST
Investigating
We are aware of an issue that is impacting certain transactions, including debit/EBT.
This issue is external to Global Payments. Our teams are working to mitigate the impact as quickly as possible. We will provide regular updates until the situation is resolved.
Posted Nov 17, 2025 - 11:24 MST
This incident affected: Heartland (NWS / PetroPay, VAPS, Exchange, Portico).