Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 24, 2026 - 19:00 MDT
Scheduled
Please see the below maintenance advisory regarding GSAP-NA (G2-NA) Platform maintenance scheduled for April 24, 2026.
Scheduled Maintenance: GSAP NA Platform maintenance Effective April 24, 2026
Please be advised regarding targeted GSAP-NA (G2-NA) Platform maintenance to be conducted on Friday April 24th, 2026. Our change window begins at 9:00pm ET and will conclude at approximately 12:00am ET next day.
Planned activities include GSAP SM database quarterly maintenance. ● Transaction Data Store (TDS) and Customer Master File (CMF) for the NA region will be unavailable between 9:00pm ET and approximately 12:00am ET next day. ● There will be no impact to transaction processing
As always, please do not hesitate to contact your Global Payments Relationship Manager with any questions regarding this announcement.
Posted Apr 15, 2026 - 16:05 MDT
This scheduled maintenance affected: Global Payments - Canada (GSAP Canada).