GPC Courtesy Advisory - CHG00050025 - May 20, 2026 - Network Maintenance in Richmond Data Center

Scheduled for May 19, 22:00 MDT  -  May 20, 05:00 MDT

Update

***Components updated to include VAPS / NWS / Exchange***

Please see the below maintenance advisory regarding Network Maintenance in Richmond Data Center scheduled for May 20, 2026.

Scheduled Maintenance: Network Maintenance in Richmond Data Center
Effective May 20, 2026

Please be advised that Global Payments will be performing network maintenance in the Richmond Data Center on Wednesday, May 20, 2026. This maintenance is scheduled to begin at 0:00 a.m. ET and ends at 07:00 a.m. ET.

During the maintenance window we do expect minimal to no impact. If you experience any issues, please follow the established escalation procedures.

As always, please do not hesitate to contact your Global Payments Relationship Manager with any questions regarding this announcement.
Posted May 08, 2026 - 10:12 MDT

Scheduled

Please see the below maintenance advisory regarding Network Maintenance in Richmond Data Center scheduled for May 20, 2026.

Scheduled Maintenance: Network Maintenance in Richmond Data Center
Effective May 20, 2026

Please be advised that Global Payments will be performing network maintenance in the Richmond Data Center on Wednesday, May 20, 2026. This maintenance is scheduled to begin at 0:00 a.m. ET and ends at 07:00 a.m. ET.

During the maintenance window we do expect minimal to no impact. If you experience any issues, please follow the established escalation procedures.

As always, please do not hesitate to contact your Global Payments Relationship Manager with any questions regarding this announcement.
Posted May 08, 2026 - 10:03 MDT
This scheduled maintenance affects: Heartland (NWS / PetroPay, VAPS, Exchange) and Global Payments - Canada (Portico Canada ATL/RIC).