Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 22, 2026 - 22:30 MDT
Scheduled
Please be advised of upcoming maintenance on the database infrastructure that supports GPeCom services. As per previous exercises, this activity is performed in an early morning maintenance slot to ensure minimal disruption to merchants.
During this maintenance slot, the database instance will be cut over to the secondary server within the same Google Cloud region, which will lead to a short period (less than 60 seconds) of impact for all services. During the downtime, merchants can expect to see either latency, failures or a combination of both.
Description: GPeCom Primary Database Maintenance
Date: April 23rd, 2026
Start time: 00:30 EDT
End Time: 02:00 EDT
Impact: While the window is 90 minutes long we estimate the impact will occur at approx. 01:00 EDT
Change #: CRQ-16087
Please reach out to your account manager if you have any questions or concerns.
Posted Apr 09, 2026 - 13:38 MDT
This scheduled maintenance affected: Global Payments - Canada (GPEcom Canada).