Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 12, 2026 - 15:15 MDT
Scheduled
Please note that Portico 3.52 Prod Release on Maple (ATL/RIC) scheduled for May 13th, 2026 has been cancelled.
Cancelled Maintenance: Portico 3.52 Prod Release on Maple (ATL/RIC) Effective: May 13, 2026
Please be advised that the scheduled Portico 3.52 Prod Release on Maple (ATL/RIC) Maintenance activity has been cancelled and it will be rescheduled to a later date.
The updated schedule will be communicated once it has been finalized.
As always, please do not hesitate to contact your Global Payments Relationship Manager with any questions regarding this announcement.
Posted May 12, 2026 - 15:10 MDT
This scheduled maintenance affected: Global Payments - Canada (Portico Canada ATL/RIC).