Heartland Debit Transactions Declining
Incident Report for Global Payments
Resolved
No further impact is occurring at this time. Our teams will continue to monitor for any additional impacts. This issue is resolved.
Posted May 07, 2024 - 10:52 MDT
Investigating
Heartland is aware of a system issue affecting some merchants who are processing debit card transactions. Merchants may see sporadic declines when processing debit transactions. This issue is external to Heartland and Global Payments. Additional updates will be provided once they become available.
Posted May 07, 2024 - 10:39 MDT
This incident affected: Heartland (NWS / PetroPay, VAPS).